SIP Connection - History

History

SIP was originally designed by Henning Schulzrinne and Mark Handley in 1996. In November 2000, SIP was accepted as a 3GPP signaling protocol and permanent element of the IP Multimedia Subsystem (IMS) architecture for IP-based streaming multimedia services in cellular systems. The IETF Network Working Group published RFC 3261 - as of 2013 the latest version of the specification - in June 2002.

The U.S. National Institute of Standards and Technology (NIST), Advanced Networking Technologies Division provides a public-domain implementation of the Java standard for SIP which serves as a reference implementation for the standard. The stack can work in proxy server or user agent scenarios and has been used in numerous commercial and research projects. It supports RFC 3261 in full and a number of extension RFCs including RFC 3265 (Subscribe / Notify) and RFC 3262 (Provisional Reliable Responses) etc.

Read more about this topic:  SIP Connection

Famous quotes containing the word history:

    “Considered in its entirety, psychoanalysis won’t do. It’s an end product, moreover, like a dinosaur or a zeppelin; no better theory can ever be erected on its ruins, which will remain for ever one of the saddest and strangest of all landmarks in the history of twentieth-century thought.”
    —Peter B. Medawar (1915–1987)

    “A people without history
    Is not redeemed from time, for history is a pattern
    Of timeless moments.”
    —T.S. (Thomas Stearns)

    “The second day of July 1776, will be the most memorable epoch in the history of America. I am apt to believe that it will be celebrated by succeeding generations as the great anniversary festival. It ought to be commemorated, as the day of deliverance, by solemn acts of devotion to God Almighty. It ought to be solemnized with pomp and parade, with shows, games, sports, guns, bells, bonfires and illuminations, from one end of this continent to the other, from this time forward forever more”
    —John Adams (1735–1826)