Open Network Computing Remote Procedure Call

Open Network Computing (ONC) Remote Procedure Call (RPC) is a widely deployed remote procedure call system. ONC was originally developed by Sun Microsystems as part of their Network File System project, and is sometimes referred to as Sun ONC or Sun RPC. ONC is considered "lean and mean", but has limited appeal as a generalized RPC system for WANs or heterogeneous environments. Systems such as DCE, CORBA and SOAP are generally used in this wider role.

ONC is based on calling conventions used in Unix and the C programming language. It serializes data using the XDR, which has also found some use to encode and decode data in files that are to be accessed on more than one platform. ONC then delivers the XDR payload using either UDP or TCP. Access to RPC services on a machine are provided via a port mapper that listens for queries on a well-known port (number 111) over UDP and TCP.

Implementations of ONC RPC exist in most Unix-like systems. Microsoft supplies an implementation for Windows in their Microsoft Windows Services for UNIX product; in addition, a number of third-party implementation of ONC RPC for Windows exist, including versions for C/C++, Java, and .NET (see external links).

ONC RPC was described in RFC 1831, published in 1995. RFC 5531, published in 2009, is the current version. Authentication mechanisms used by ONC RPC are described in RFC 2695, RFC 2203, and RFC 2623.

In 2009, Sun relicensed the ONC RPC code under the standard 3-clause BSD license and then reconfirmed by Oracle Corporation in 2010 following confusion about the scope of the relicensing.

Famous quotes containing the words open, network, remote and/or call:

    “It will open a door through which fools and fanatics will pour in, and make the cause ridiculous.”
    —Jane Grey Swisshelm (1815–1884)

    “How have I been able to live so long outside Nature without identifying myself with it? Everything lives, moves, everything corresponds; the magnetic rays, emanating either from myself or from others, cross the limitless chain of created things unimpeded; it is a transparent network that covers the world, and its slender threads communicate themselves by degrees to the planets and stars. Captive now upon earth, I commune with the chorus of the stars who share in my joys and sorrows.”
    —Gérard De Nerval (1808–1855)

    “The Americans never use the word peasant, because they have no idea of the class which that term denotes; the ignorance of more remote ages, the simplicity of rural life, and the rusticity of the villager have not been preserved among them; and they are alike unacquainted with the virtues, the vices, the coarse habits, and the simple graces of an early stage of civilization.”
    —Alexis de Tocqueville (1805–1859)

    “We have what I would call educational genocide. I’m concerned about learning totally, but I’m immersed in the disastrous record of how many black kids are going into science. They are very few and far between. I’ve said that when I see more black students in the laboratories than I see on the football field, I’ll be happy.”
    —Jewel Plummer Cobb (b. 1924)